Joined: Jan. 2009
||Posted: Jan. 13 2009,01:59
OK, I managed to force in fileutils by
dkpg -i --force-overwrite /var/cache/apt/archives/fileutils*
... lots of warnings about package overlaps, but seems to work.
Now, to get the include files (/usr/include/*.h) needed to compile anything useful. It looks like I should be able to install them with
apt-get install libc6-dev
... but libc6-dev requires libc6 of a specific revision ?
"" libc6-dev: Depends: libc6 (= 2.2.5-11.8) but 2.3.2.ds1-10 is to be installed ""
For the things I want to compile, it is extremely unlikely that the differences between libc6 versions can be ignored (after all, stdio.h has not changed in a long time), so I thought I would just force the dependency checking to be ignored for this version as well, but I cannot get apt-get to download the package.
apt-get install -f libc6-dev
apt-get -f install libc6-dev
apt-get install libc6-dev -f
... but I still get the same message that it failed to install due to the version problem.
Clearly, my problem is unfamiliarity with the debian package manager (I'm used to the RedHat tools).
/ Lars Poulsen