Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: Time-outs and download/install issues< Next Oldest | Next Newest >
randomtrouble Offline

Group: Members
Posts: 5
Joined: Dec. 2006
Posted: Dec. 04 2006,23:49 QUOTE

When I try to compile a program using Scons, I get this message: "sh: line 1: sdl-config: command not found............. Error: cant execute sdl-config, make sure SDL is installed..........TypError: 'str' object is not callable: File 'SConstruct', line 65: exit(255);"

So I contacted the author of the application I'm trying to compile, and he said I needed libsdl1.2-dev (I have already installed libsdl1.2debian). However, when I try to perform APT-GET INSTALL LIBSDL1.2-dev I get this message:

"Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report agains that package should be filled. The follow info may help to resolve the situation: The following packages have unmet dependencies: libsdl1.2-dev: Depends: xlibs-dev but it is not going to be installed...... E: Broken packages"

1) Requested an impossible situation? I doubt that, I simply tried to install a package.
2) Required packages not moved out of Incoming? For all that I know, that might be.
3) Unmet dependencies? That xlibs-dev must be installed for libsdl-dev to be installed? Well, when I try APT-GET INSTALL XLIBS-DEV I experience the same kind of error as I got when trying to install libsdl-dev.

I sincerely don't know what to do. I have tried quite intensely.

- Oh, another issue about updating and downloading packages. I    
often have to perform "APT-GET UPDATE" 10 times before it does not time out. Is this very common? More concretely... it works, and reaches a certain level of percent, let's say 25 %, and it goes: " 25 % - - - -  STALLED - - - - ". Is this very common? Anyway, this is not as critical as the real problem I explained earlier. Because, I may after all repeat the command until it doesn't time out. But it'd be nice not having to do this.
Back to top
Profile PM 
0 replies since Dec. 04 2006,23:49 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: Time-outs and download/install issues

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code