Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: alsa sound driver gives no sound, modprobe can't locate sound-slot-0< Next Oldest | Next Newest >
Giftmischer Offline

Group: Members
Posts: 11
Joined: July 2006
Posted: July 15 2006,21:15 QUOTE


I have tried to configure the alsa sound driver like it's described in the file:

1. Start up DSL with the "dsl alsa" boot command. /* I wrote this to /etc/lilo.conf */
2. Install the gnu-utils.dsl myDSL extension.
3. Install the dsl-dpkg.dsl myDSL extension.
4. Install this extension alsadebs.dsl
5. Choose "Install ALSA" from the myDSL menu.

After this alsa was load during the dsl boot process. But after the alsa sound card detecion there appears some errors:

1st:   sth like "/etc/initr.d missing /var/"
I fixed it by creating "/var/" (empty file) and the error disappears.

2nd:  sth like "modprobe module sound-slot-0 can't be located"
I don't know what I should do because while alsa is "running" the
programs like xmms or audacity displaying an I/O error window.

How can I fix this?

btw: I have no internet connection on dsl. @Piccolo: So I can't get sndconfig.

Greetings & cheers by

Azathoth uses M$ winblows
Back to top
Profile PM WEB ICQ 
roberts Offline

Group: Members
Posts: 4983
Joined: Oct. 2003
Posted: July 16 2006,04:32 QUOTE

Alsa is not part of the base DSL system. It is an extension. Your post has been moved to the proper section.
Back to top
Profile PM WEB 
mm0zct Offline

Group: Members
Posts: 1
Joined: Aug. 2006
Posted: Aug. 13 2006,23:57 QUOTE

i have a similar problem, although it wanted the file in /var/tmp/ creating the file (empty) did seem to get around the error.. the install script ends at the same point anyway, without error

root@box:/home/dsl# bash /opt/alsadebs/install_alsadebs
(Reading database ... 10841 files and directories currently installed.)
Preparing to replace alsa-headers 1.0.4-3 (using .../alsa-headers_1.0.4-3_i386.deb) ...
Unpacking replacement alsa-headers ...
Preparing to replace aumix 2.7-18 (using .../alsadebs/aumix_2.7-18_i386.deb) ...
Unpacking replacement aumix ...
Preparing to replace knx-alsa 0.1-8 (using .../knx-alsa_0.1-8_i386.deb) ...
Unpacking replacement knx-alsa ...
Preparing to replace libasound2 1.0.4-1 (using .../libasound2_1.0.4-1_i386.deb) ...
Unpacking replacement libasound2 ...
Preparing to replace libgpmg1 1.19.6-12 (using .../libgpmg1_1.19.6-12_i386.deb) ...
Unpacking replacement libgpmg1 ...
Preparing to replace libncurses5 5.4-3 (using .../libncurses5_5.4-3_i386.deb) ...
Unpacking replacement libncurses5 ...
Preparing to replace pciutils 1:2.1.9-4 (using .../pciutils_1%3a2.1.9-4_i386.deb) ...
Unpacking replacement pciutils ...
Setting up alsa-headers (1.0.4-3) ...
Setting up libasound2 (1.0.4-1) ...

Setting up libncurses5 (5.4-3) ...

Setting up pciutils (2.1.9-4) ...

Setting up knx-alsa (0.1-8) ...
Preparing modules for alsa...
Preparing master knoppix for alsa...

Setting up libgpmg1 (1.19.6-12) ...

Setting up aumix (2.7-18) ...

Preparing modules for alsa...
Building card database..

like so

although it has built the card database in the file i created, it doesn't appear to continue. am i missing something here? like the nwext step?
Back to top
Profile PM 
2 replies since July 15 2006,21:15 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: alsa sound driver gives no sound

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code