Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: Motion and green image ?, Motion with support of Philips Webcam< Next Oldest | Next Newest >
tanguy Offline

Group: Members
Posts: 2
Joined: Feb. 2006
Posted: Feb. 15 2006,09:33 QUOTE


i've installed the motion dsl extension, but i've a problem with my webcam a 840K Philips,
motion recognize it but the image is green

i've another old webcam a philips again
but it could be not initialized ( problem of decompression module in pcw if i understand )

Anyone have recompiled a version with new version of pwc driver

If you use this package could you say what model of webcam you use
Many thanks
Back to top
Profile PM 
newOldUser Offline

Group: Members
Posts: 241
Joined: Oct. 2004
Posted: Feb. 15 2006,12:06 QUOTE

I use it once in a while with an old Dlink dsb-c100 camera that I bought for $10 years ago.

I thought the picture was fuzzy, out-of-focus and hard to look at but then I realized that was just the way I looked.  

Have you downloaded GQCam from MyDSL and tried the camera with that? If you can get it working with GQCam then it's just a config problem in motion.

I thought the Philips series of webcams were suppose to work OK.

I know the logitech series of webcams need the spca5xx driver that dsl doesn't have. There's an interesting page over at the Ubuntu Forum that talks about compiling the driver if someone is adventurous.

Have you looked around on the Motion Home Page to see if there is anything about your camera?

-Good luck

======== Note =========
The DSL Forum Search default is 'OR'
If you search for "cat dog" you will get all "cat" posts and all "dog" posts.
If you search for "cat AND dog" you will only find results that contain BOTH "cat" and "dog"
Add '*' for wildcards, " cat* and dog* "
Back to top
Profile PM 
tanguy Offline

Group: Members
Posts: 2
Joined: Feb. 2006
Posted: Feb. 16 2006,06:58 QUOTE

Thanks for answer

I've install GQCam  and i've a little black and white image

My screen is decomposed in three part
at the top i see the real image three times in very small
in the middle a band of something !! who change a bit when i moved my webcam
at the bottom a large band of grey with nothing

image | image | image
band with something
large grey band with nothing

If you can an idea
or can give a name of a webcam you test and working

Many thanks for your help again
Back to top
Profile PM 

Posted: Feb. 18 2006,14:14 QUOTE

That's what I found on usenet Quote:
From: KarlD - view profile
Date: Thurs, Aug 25 2005 6:03 pm
Not yet rated
show options

Update on webcam installation on Mdk 10.0.

I finally got a Logitech quickcam 4000 pro working. The steps I
did is outlined below.
I haven't figured out how to get the microphone on the cam to
work yet. I don't know what audio module I need to load to get
the USB audio class properly registered but the webcam
works fine in 640x480 resolution at 15 fps.

The main issue I had was that the pwc module that
was shipped with the Mdk 10.0 distribution and whas loaded
when I first plugged in the camera did not work. Apparently
I needed som extra compression module that was not included.
The development of the Philips pwc driver has been
transferred over from Nemosoft to
and the new version does not need the separate pwcx
decompression module.

I downloaded the pwc-10.0.4.tar.bz2 package and
compiled it and removed the old driver:
# rm /lib/modules/2.6.3-7mdk/kernel/drivers/usb/media/pwc.ko.gz
# cp pwc.ko /lib/modules/2.6.3-7mdk/kernel/drivers/usb/media/
# depmod -a
# rmmod pwc
# rmmod pwcx
# modprobe pwc

and the camera worked on the fly, tried xawtv and camstream

Quote end.
As  DSL_OS is kernel 2.4.x we should try to compile a module for it. If I had some more time I'd do it. Let's see.

Back to top
3 replies since Feb. 15 2006,09:33 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: Motion and green image ?

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code