Damn Small Linux - Not!
The forum for DSL-N
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

HP952 USB Problems

Post new topic   Reply to topic    Damn Small Linux - Not! Forum Index -> Printing
View previous topic :: View next topic  
Author Message

Joined: 16 Aug 2006
Posts: 4

PostPosted: Wed Aug 16, 2006 1:52 pm    Post subject: HP952 USB Problems Reply with quote

Please see new update below - 08/17/06

I am a Linux newbie,but a computer oldie, so please be gentle.

I am trying out DSL-N.

I am trying to install an HP Deskjet 952C on a USB port on an old Pressrio 1200XL with a 4 GB HD and 192 RAM. I want to move to Linux once I am assured it will work.It has a sinlge USB port. I cannot get the printer to print from the USB port. It does however work from the parallel port (remember those).

Here is what I havedone.
1. Start CUPS from panel
2. Start Printer Setup - I have to change the root passwd to get into the Printer setup
3. Give name, etc, select USB 1, select HP and select HP990 series with CUPS
4. Go to printer manager and see it shows green for the printer.
5. I then try to print a Test PAge, but nothing happens.

When I return to theprinter page I get either a No Page FOund messgae OR the following
"Unable to open USB port device file "/dev/usb/lp0": No such device"

Remeber I am new so I am not always sure what to check when. I did a lsusb and see
that the printer is listed (but as HP959) on Bus 001: Device 2 (Bus 001 Device 1 is blank)

Again the printer does owrk off the parallel port but not the usb port. Also, I cannot get a Linksys WUSB11 V3 wireless adatper to workoff the usb port either and I am wondering if it is a similar problem.

Please Help - I really want to move to Linux as soon as I can confirm it will work satisfacorily with my equipment.

Update #1 08/16/06: I checked DMESG and found the following:
parport0:Printer,HP Deskjet 950C -- guess this confirms it is being detectedon the parallel port - which of ocurse I know already, BUT I do not see a similar type message for the USB Port. .

Update #2 - 08/17/06 Today I tried my USB Pendrive in the USB port. DSL-N correctly identified it and I was able to MOUNT it and view it contents leading me to believe that the USB port is functioning properly. But I am still unable to get the HP952 Printer going. It is recognized when I do lsusb (though shows it as an HP 959 which I believeis the same class). I can seemingly configure it (I have tried several drivers, but cannot print. I still get a Unable to open usb port lp0 message or a No page found message. Can anyone advise me of what to do next. THank You.

Thanks!!! JMF

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Damn Small Linux - Not! Forum Index -> Printing All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group