Talk:Floppy Only Install with Netcard (Poormans Install)

From DSL Wiki

What is the password of root after install the dsl? There is a non-root user logon by default.


Error message




I get the error message: 25: Syntax error: ";" unexpected

Not being a shell programmer I helped myself by changing the lines 25 and and 31 in:

  • if test "$SOURCE"; then echo "$SOURCE"; else
  • if test "$TARGET"; then echo "$TARGET"; else

I had to change the mount-command in line 51 from:

mount /mnt/$SOURCE/current.iso /mnt/iso -t iso9660 -o loop=/dev/loop0


mount /mnt/$SOURCE/current.iso /mnt/iso -t iso9660 -o loop /dev/loop0

then everything went o.k.

Maybe it's because I'm not using TOMSRTBT as suggestet in the article but BG Rescue-Linux

Greeting Beda (beda (at) muri-gries ch)

Additions and Corrections to "Error message"

* To do the previous discussed things inside of BG-RESCUE Linux, use the vi editor: # vi
* For more information about the vi editor, try locating information on the internet

changes in the skript


why don't you make the changes http an linux allready in the skript. it's a bit anoying to change this with a wronge keyboard setting. And if it's in your tutorial, everyone would make it anyway. So please update this on the mirror.

greets fr3ddy -- 30 July 2007 18:38 (EDT)

Are the changes even needed? I was getting errors when the script tried to get from the http source, so I changed it back to the original ftp address and it seems to be working fine now. (I also had to make the edits to the if-then statements mentioned above)

Problems with old computer

Hey all. This article has the propensity of being hugely helpful. I'm trying to get linux on an old compaq: 75mhz 24mb ram system. the only removable storage is the floppy drive. i also have a pcmcia external harddrive and a few pcmcia ethernet cards. i know that one of the ethernet cards, a netgear, uses the driver: "pcnet_cs". the floppy drive doesn't support the formatting used by the first mini-distro recommended, and the second mini-distro results in a sudden crash-and-reboot shortly after loading intrid. i found a distro called hal19 that was recommended on another site, and it works well - but it doesn't recognize my ethernet card, as far as i can tell. running "ifconfig" returns nothing. running hal91's script puts a loopback device under ifconfig, but thats all. how can i compile a floppy distro that allows my ethernet card to function, so i can download a linux distro and boot it?

One possibility is to use a hack of kexec to manipulate the boot process. However, that thing is still being enhanced by various hackers/programmers. Some projects have been made, but it's a useful tool. Kboot is one of the more maintained projected that revolve around kexec. That's a really old computer, though. I mean, really old. Do yourself a favor and toss it unless there is no better alternative.

Poorman's Concept

Follow-up Question: Are you sure this is considered a poor man's install?

For what I remember, a poor man's install is one where you are able to boot the iso completely into RAMdisk, thus detaching it from other disk media. How exactly did those formerly discussed computers load DSL into RAM? A computer needs at least 128 MB for DSL to do that. Am I wrong?

Another Error message

Hi, after the reboot by floppy, the DSL told me that it "can't find KNOPPIX filesystem".

Therefore, I ran the a second time and find out the reason: While the decompressing and copying of the image, a message appears, which says, that there is "KNOPPIX: no such file or directory". I opened the script a second time and added the line "mkdir mgt/KNOPPIX" and "cp mgt/iso/KNOPPIX mgt/$TARGET/KNOPPIX" (originally, the target directory is only mgt/$TARGET) and then everything worked fine. I'm at the moment a little bit unsure about the directory names, but I hope, they're correct. In conclusion, the problem was, that the dirctory "KNOPPIX" didn't exist. Greetings and sorry for my English, I'm a German ;-)