What's the best way to get apt-get on DSL-N

Forum: Apt-get
Topic: What's the best way to get apt-get on DSL-N
started by: mkenyon2

Posted by mkenyon2 on Aug. 07 2008,16:22
What is the best way to get apt-get and/or dpkg on DSL-N?

I tried the dsl-dpkg.dsl extension from the dsl sight, but that has issues.

Posted by lucky13 on Aug. 07 2008,19:13
There's a separate forum area for DSL-N. I touched briefly on this issue on my blog yesterday. Debian no longer supports the version that was concurrent with Knoppix 3.4 and DSL. Don't expect DSL to support what Debian doesn't. You can go to their site and see what they have to say to users still using Woody: update to a supported version.

If you've done a hard drive install of either DSL or DSL-N, you need to understand that while its base *can* install to a Debian-like state, it isn't in a Debian-like state. It's been modified for use as a live CD (Knoppix) then further un-Debianed in DSL.

Some of the app and lib versions are risky at this point on a traditional hard drive install unless you're willing to manually update quite a few things. They're safer on a frugal install since the base is read-only. Any rw mounted (or mountable) media can still be compromised via any vulnerabilities and if you're careless.

Posted by WDef on Aug. 07 2008,20:04
I think dsl-n's parent Knoppix was based on Sarge iirc (?). I seem to recall bothering Robert on the forum until he told us.

No matter. Tend to think that, as much potential as a dsl-n type system had (I liked it a lot), it's a bit of an orphan now, so the OP would have to have some special reason for needing it.

If the OP needs a 2.6.xx kernel then it may perhaps be better to either wait for tinycore to reach a beta release or look elsewhere in the meantime.  Either that or just hope that some of the dsl-n enthusiasts around will continue to provide some support in the forum, but unfortunately dsl-n is unmaintained and its days are probably numbered.

Posted by lucky13 on Aug. 07 2008,21:21
I liked DSL-N a lot, too, and booted it a few days ago for the first time in about a year (same for the last 2.4 versions of Knoppix and Mepis). The same issues would pertain whether Woody or Sarge -- Debian announced end-of-life security support for Sarge earlier this year. (Insert my customary message that Microsoft offers longer support for its releases than most Linux distros despite the ecstatic frenzy of advocates about "planned obsolescence" and other anti-Windows FUD.)

RIP, Sarge:
< http://www.debian.org/News/2008/20080229 >

Posted by WDef on Aug. 07 2008,22:30
The worst offender is Fedora, with its exhausting release cycle (exhausting for users trying to keep up that is) and short support period.

After they got the new ceo they increased the security support lifetime to from 1 year to 18 months I think it was.  But they'd already lost a lot of users to Ubuntu who were sick to death of f*ck*ng yum and updating every six months and breaking things, and people got wise that Fedora was just a testing ground for the latest libraries and experiments for RHEL, though they claim it isn't and have deliberately veered away from RH to some extent to try for their own identity.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.