Installing Intel e1000e drivers

Forum: Networking
Topic: Installing Intel e1000e drivers
started by: bartgrefte

Posted by bartgrefte on April 13 2009,10:52

just tried to install Intel's e1000e driver (e1000e- for two onboard Intel 82574L GbE NIC's on the frugal install I've got running with the toram option.

Did "tar zxf e1000e-", followed by "cd e1000e-".
Then the "make install" command, but the "make" command is not recognized...

Before someone mentiones it, I know there's already an e1000 driver present in DSL (read that somewhere on the forum), but according to Intel I have to use the e1000e driver, which I can't get installed.

So tried the already present e1000 driver anyway with "sudo modprobe e1000", get something like this:

/lib/modules/2.4.31/kernel/drivers/net/e1000/e1000.o: init_module: no such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg.
/lib/modules/2.4.31/kernel/drivers/net/e1000/e1000.o: insmod /lib/modules/2.4.31/kernel/drivers/net/e1000/e1000.o failed
/lib/modules/2.4.31/kernel/drivers/net/e1000/e1000.o: insmod e1000 failed

Any idea how to get both NIC's working?

With regards,

Bart Grefte

Posted by bartgrefte on April 14 2009,10:41
Got the make command working, but now I need some development package with kernel sources.....

DSL wouldn't find the kernelsources, after I installed it with MyDSL.

After reboot the DSL files weren't loaded anymore, so here's another problem/question: How do I get DSL to load those DSL files during boot?

Tried adding this bootoption to the lilo.conf file on the CFcard: mydsl=hda1/MyDSL , where I placed the .DSL files.
Didn't help.

Posted by bartgrefte on April 15 2009,10:36
Found out that I had the wrong kernelsources file, my DSL is a bit more recent.

So make install workes now, more or less.
Lot's of stuff (text) fly by on the console, ends with : "make: *** [install] error 1"...

And saw this a lot "warning: dereferencing type-punned pointer will break strict-aliasing rules".

Both modprobe and insmod say "module not found".

And, although somewhat offtopic, I can't change the hostname.
Adding "host=hostname" in the lilo.conf of the frugal install doesn't change anything...
Yes, it's in the right line, next to "mydsl=hda1/mydsl". (.dsl's are loading now btw :) )

Posted by bartgrefte on April 19 2009,12:01
Great, that Intel driver f*cked up things in such a way that DSL lost the settings it had saved and it won't save them anymore.

So with every boot I now get DSL X Setup again, and DSL keeps losing the setting where the device is specified to backup to...

Trying to start all over now...

What the...
I entered the hostname bootoption during installation instead of after. Now the hostname is changed, but part of it (last 6 characters) are missing?!?!?!

New nickname set as: BocaDelInfierno (Those who watch Buffy the vampire slayer will get it ;) )
But I only get "BocaDelIn"....

Posted by mikshaw on April 20 2009,13:12
When using Lilo you have to run the lilo command in order to apply changes.

There is a limit to the number of characters you can use for a hostname, apparently to prevent problems with applications that use hostname.  As  I understand, it is recommended that you use 8 or fewer characters to be assured that every app will return the same hostname.

P.S. Please don't send tech questions through the private message system; they will usually be ignored. The forums are intended to assist everyone, now and in the future. PMs help only one person, one time.

Posted by bartgrefte on April 20 2009,15:01
Yeah I know, found that command somewhere (hard to find the one which solves the "readonlly FS" error), but doesn't help.
The hostname only changes when I add the host= option during install, not after...

Recommended, but more possible?
My Windows XP computer has one with 14 characters, works fine.
edit: wait, you said 8, it shows 9 characters...
And I've read about this problem somewhere on the forum, if only I can just find that topic again...

Well, I hate waiting for week(s), that's why the pm.

Now to solve the problem with the Intel network driver that still isn't working, and I also would like to know why GRUB isn't working on this particular computer (see < other topic > of mine).

Posted by mikshaw on April 21 2009,00:37
Recommended, but more possible?...wait, you said 8, it shows 9 characters
More are possible, but it is limited by the distribution. I've seen somewhere that the limit is shown in a header in /sys, but since DSL doesn't have anything there I don't know what DSL's limit is...apparently it's 9.
I think the maximum (if the distro doesn't limit it) is 32? Keep in mind that if an application uses hostname but only supports 8 characters, that application would retrieve an incorrect name.  As far as I know, that's the reason for the 8-character recommendation.

Posted by bartgrefte on April 21 2009,10:00
Hostname problem fixed. :)

I put the host= option before ssh and toram instead of after.
Now I see the full hostname.

But... Now the backupfunction doesn't work anymore, DSL keeps showing that "DSL X Setup" during boot.
Yes, I've entered a device to save the settings to, like I did the previous times I installed DSL, but now it wont save (or load?) the settings.

Didn't do something to cause that, I think.

Ran the mke2fs command at the console while DSL was running from cdrom. (partition was already made)
Installed frugal Lilo, with the host= ssh and toram bootoptions.
Entered (when asked) a location for MyDSL.
After installation I mounted the CF-card and copied over the mydsl folder.
Removed DSL cdrom and reboot.
After booting I entered hda1 as backuplocation, like I did several times before...

Making the backup seems to go fine, but DSL won't load the saved settings anymore. ???

Posted by mikshaw on April 22 2009,12:33
Changing the order of boot options shouldn't make a difference.  I'm guessing the extra length of the hostname may be adversely affecting some programs?

What does the /proc/cmdline file contain?

What happens if you reduce the size of host name to 8 characters, without making any other changes?  If that fixes the trouble then you'll know long hostnames are not a good idea.

Posted by bartgrefte on April 23 2009,13:55
Apparently it does, so it seems.
Don't know, if that is the case, weird...

/proc/cmdline : (before I cut the hostname)
auto BOOT_IMAGE=DSL ro root=301 ramdisk_size=100000 init=/etc/init lang=us apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi nomce nodma quiet frugal BOOT_IMAGE=/KNOPPIX/KNOPPIX fromhd=/dev/hda1 host=BocaDelInfierno ssh

Should that line look the same like one in the lilo.conf file?
It's because I see something, well, not see something actually.
The mydsl= option isn't there at the end of the line, but it is there, and working, in the lilo.conf.

Hostname cut to 7 characters, didn't help.

Posted by mikshaw on April 24 2009,10:50
Then I guess maybe it's not an issue with hostname, so it's weirder than I thought.

I have no idea what some of those boot options are...maybe something in there is affecting things.
For all I know there might be a limit to the size of /proc/cmdline.  Seems like that would be a bad idea, though.

One thing I'd try is the dmesg command to look for errors.

Posted by bartgrefte on April 24 2009,18:40

Those bootoptions where all there after installation, not counting the ones I added: host=name, toram, ssh. Mydsl=hda1/mydsl is there as well (in the lilo.conf). But that one got added by the installer.

Before I post both (yes, two) dmesg-files, I solved the backup problem :): I added restore=hda1 to lilo.conf, which wasn't necessary the first several installations I might add...
After I did that, the backup-file (that seemed to have been created successfully the last time I tried) was automatically loaded.

< dmesg1 > (backup not working)
< dmesg2 > (backup working)
< lilo.conf > (Deleted those hd*=scsi options besides hda=scsi, to clear things up a bit.)

And I've set back the hostname I wanted to use, which is completely displayed: BocaDelInfierno :)

This weekend I'm gonna try the Intel NIC driver again.
Already contacted the guy who made the kernelsources.dsl, thought the problem was related to that.

Posted by bartgrefte on April 26 2009,17:02
Still can't get the driver working..

Here's some text from the console/terminal that I got after entering the make install command:
< >
First part is missing since the console didn't held on to it...

After that I ran a search, the module isn't where it's supposed to be ("/lib/modules/2.4.31/kernel/drivers/net/e1000e/e1000e.o"
if I'm correct). Instead it seems to be in the src folder of the extracted content of the tar.gz driver file.

So I tried these:
"modprobe /home/dsl/e1000e-" and "modprobe /ramdisk/home/dsl/e1000e-"

Both "can't locate module", but it's there! Okay, in the wrong place, but why can't DSL find it even though I entered the full path?

Posted by bartgrefte on May 04 2009,15:06
Solved :)

Adding this to the did the trick:

insmod /home/dsl/e1000e-

pump -i eth0
ifconfig eth1 netmask

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.