blkid_known_fstype - mounting FAT16 partition

Forum: HD Install
Topic: blkid_known_fstype - mounting FAT16 partition
started by: janx

Posted by janx on Mar. 15 2009,10:54
I have completed a frugal install on a machine with 2 Windows partitions (FAT16). Here are the errors I am getting when I try to mount the second partition:
[/home/dsl]# mount /dev/hda2
mount: relocation error: mount: undefined symbol: blkid_known_fstype
[/home/dsl]# mount -t vfat /dev/hda2 /mnt/hda2
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
      or too many mounted file systems

Is there a maximum number of mounted file systems?

However, hda1 can be mounted without problems (and I remember that initially I was able to mount hda2).

I copy below fstab, mtab and menu.lst entry (grub).

Any help would be appreciated.

/proc      /proc       proc   defaults            0 0
/sys       /sys        sysfs  noauto              0 0
/dev/pts   /dev/pts    devpts mode=0622           0 0
/dev/fd0   /mnt/auto/floppy auto   user,noauto,exec,umask=000    0 0
/dev/cdrom /mnt/auto/cdrom  auto   user,noauto,exec,ro 0 0
# Added by KNOPPIX
/dev/hda1 /mnt/hda1 vfat noauto,users,exec,umask=000,uid=1001,gid=50 0 0
# Added by KNOPPIX
/dev/hda2 /mnt/hda2 auto noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda3 /mnt/hda3 ext2 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda5 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda6 /mnt/hda6 ext2 noauto,users,exec 0 0

/dev/root / ext2 rw 0 0
/dev/hda3 /cdrom ext2 rw 0 0
/dev/cloop /KNOPPIX iso9660 ro 0 0
/ramdisk /ramdisk tmpfs rw,size=21744k,size=66486k 0 0
unionfs /KNOPPIX/bin unionfs rw,dirs=/ramdisk/bin=rw:/bin=ro 0 0
unionfs /dev unionfs rw,dirs=/ramdisk/dev=rw:/dev=ro 0 0
unionfs /etc unionfs rw,dirs=/ramdisk/etc=rw:/etc=rw 0 0
unionfs /KNOPPIX/lib unionfs rw,dirs=/ramdisk/lib=rw:/lib=ro 0 0
unionfs /KNOPPIX/sbin unionfs rw,dirs=/ramdisk/sbin=rw:/sbin=ro 0 0
unionfs /KNOPPIX/usr unionfs rw,dirs=/ramdisk/usr=rw:/usr=ro 0 0
unionfs /ramdisk/var unionfs rw,dirs=/ramdisk/var=rw 0 0
/dev/hda6 /mnt/hda6 ext2 rw,nosuid,nodev 0 0
/mnt/hda6/home/dsl /ramdisk/home/dsl none rw,bind 0 0
/mnt/hda6/opt /opt none rw,bind 0 0
/mnt/hda6/mydsl/alsa.unc /opt/alsa iso9660 ro,loop=/dev/cloop1 0 0
/mnt/hda6/mydsl/firefox-gtk1.2-1.0.6.uci /opt/firefox-gtk1.2-1.0.6 iso9660 ro,lo
op=/dev/cloop2 0 0
/mnt/hda6/mydsl/gnu-utils.unc /opt/gnu-utils iso9660 ro,loop=/dev/cloop3 0 0
/mnt/hda6/mydsl/skype- /opt/skype- iso9660 ro,loop=/dev/cloo
p4 0 0
/dev/hda1 /mnt/hda1 vfat rw,nosuid,nodev,umask=000,uid=1001,gid=50 0 0

kernel /boot/linux24 root=/dev/hda3 quiet vga=788 noacpi noapm nodma noscsi vga=
788 home=hda6 opt=hda6 xmodule=fbdev apm=power-off noapic nomce alsa lang=fr dsl
mydsl=hda6 frugal
initrd /boot/minirt24.gz

Posted by janx on Mar. 22 2009,22:08
OK, these messages mean that the file system is corrupted.
The problem is that apparently it was corrupted when mounted by DSL (as msdos / vfat).
No other solution than reformatting.

Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.