Forum: Other Help Topics
Topic: booting
started by: rgs3542

Posted by rgs3542 on Feb. 02 2009,15:58
I am using DSL as a kind of router -- more of a packet-forwarding device -- on a very private networking system to connect one network IP scheme to another. Tweaking the configures my NICs and starts the forwarding but I have to log in to get it to start.

Is there a way of starting the networking, etc without doing the log in?

The reason I ask is that if we lose power and the "router" goes down, I would like the "router" to come back up when the power is restored and me not having to hoof to it to log in.

FYI: this "router" is a Wyse WinTerm with DSL installed and a 3Com NIC added. I love DSL and have ordered the book hoping that it will have information on this.

Posted by rgs3542 on Feb. 02 2009,17:45
Further developments: when it boots, it uses the proscribed IP addresses for about 26 seconds then loses them. Most peculiar. Then I log in as "dsl" and the NICs are up and running again. Weird.
Posted by Tobiaus on Feb. 03 2009,17:44
message removed
Posted by rgs3542 on Feb. 04 2009,03:32
I tried copying the /etc/inittab file from a CD-ROM-booted version of DSL since it logs into itself as user dsl when you boot from the CD. I think I got tangled up in the ::respawn commands and ended up with a box that wouldn't boot at all. It sat stunned with a 'no more processes in init 5' message and no cursor. Toast time! So I'll try again tomorrow.

Thanks for the input. I eagerly await my book.

Posted by Tobiaus on Feb. 04 2009,05:37
message removed
Posted by rgs3542 on Feb. 04 2009,14:35
I apologize; yes, it was a full-install. Note the past tense.

Taking your advice, I've toasted it and done a frugal install. After tweaking the to do the ifconfig and ip_forwardiing-stuff, I got it to save the changes. And now it seems to come up, config the NICs and just sit there, exactly what I want it to do. I'm still testing but it looks very promising.

Gotta love DSL and the DSL community. Thank you.

Posted by Tobiaus on Feb. 05 2009,02:25
message removed
Posted by rgs3542 on Feb. 10 2009,22:28
My testing proved premature. Upon further rumination, one of the CD boot options is "nodhcp" which does exactly that.

So I re-installed (frugal grub) and when the installation procedure prompted me for boot options, I entered "nodhcp" and "ssh" and completed the installation. I then added all the NIC configs, ip_forward and sshd commands into /opt/ I added a password for root and added /etc/shadow to the .filetool.lst.

Now she boots unattended, configures the NICs, starts sshd (so I can get into her should the need arise) and start forwarding packet immediately.

Posted by Tobiaus on Feb. 12 2009,16:22
message removed
Powered by Ikonboard 3.1.2a
Ikonboard © 2001 Jarvis Entertainment Group, Inc.