Apt-get :: Installing MAKE

OK, I managed to force in fileutils by
   dkpg -i --force-overwrite /var/cache/apt/archives/fileutils*
... lots of warnings about package overlaps, but seems to work.

Now, to get the include files (/usr/include/*.h) needed to compile anything useful. It looks like I should be able to install them with
   apt-get install libc6-dev
... but libc6-dev requires libc6 of a specific revision ?
""  libc6-dev: Depends: libc6 (= 2.2.5-11.8) but 2.3.2.ds1-10 is to be installed ""

For the things I want to compile, it is extremely unlikely that the differences between libc6 versions can be ignored (after all, stdio.h has not changed in a long time), so I thought I would just force the dependency checking to be ignored for this version as well, but I cannot get apt-get to download the package.

I tried
   apt-get install -f libc6-dev
   apt-get -f install libc6-dev
   apt-get install libc6-dev -f
... but I still get the same message that it failed to install due to the version problem.

Clearly, my problem is unfamiliarity with the debian package manager (I'm used to the RedHat tools).

/ Lars Poulsen

Oh dear.

dsl is only partially debian compatible. You do not need to do these machinations with apt-get to just get make and so on.

make is included in compile.uci, along with gcc, binutils and a lot of headers

Use that to compile.  Read the info file for instructions.


Getting Started with Damn Small Linux

That's why it opens when you boot.

Thank you for the somewhat helpful reply.

I have not managed to figure out how to "use compile.uci"

I found a utility named something like DSL UCI Browser,
but compile.uci is not amoung the options that it shows.

The irony is that I have been managing Unix systems since
1982, but find DSL almost as confusing as System V.

Ahhh ... I found compile.uci ... in the TESTING section of
the "UCI Browser".

I selected it, pushed "install selected". A command script ran (and its window closed before I could read anything in it).
A bunch of stuff got downloaded, but /usr/include is still
pretty empty. For example, there is no stdio.h

So you have read


And the rest of the wiki and the FAQ?

uci extensions mount in their own dir in /opt, they mainly do not install to the root filesystem.

dsl has always required some reading.  Just about every conceivable question has been asked before - suggest making generous use of the forum search capability.

At present the community here is in disarray, since a bunch of the most experienced users are not around much since Robert left.

original here.