Apt-get :: invoke-rc.d

I found out the existence of this fundamental script (supposed to be used by all Debian packages needing to run a /etc/init.d script) through  an unsuccessful apt, so I guess this is the place to post this issue.
I am using DSL3.3 but I changed my source to sarge. It might be the reason for my problem.
I initially thought invoke-rc.d might be missing but there is /sbin/invoke-rc.d. Just its behavior is:
Code Sample
root@ttyp1[root]# invoke-rc.d --help
invoke-rc.d: applet not found

I tried to update the corresponding package (I may be wrong on that):
Code Sample
root@ttyp1[root]# apt-get install file-rc
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 142 not upgraded.
2 not fully installed or removed.
Need to get 36.3kB of archives.
After unpacking 193kB of additional disk space will be used.
Get:1 http://archive.debian.org sarge/main file-rc 0.8.7 [36.3kB]
Fetched 36.3kB in 1s (19.6kB/s)                        
Selecting previously deselected package file-rc.
(Reading database ... 13218 files and directories currently installed.)
Unpacking file-rc (from .../archives/file-rc_0.8.7_all.deb) ...
dpkg: error processing /var/cache/apt/archives/file-rc_0.8.7_all.deb (--unpack):
trying to overwrite `/etc/init.d/rc', which is also in package sysvinit
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Does anybody know what is going on here?

I'm not sure what sarge corresponds to, but I would guess it is oldstable whereas DSL now corresponds to +/- old-oldstable (archived). Did you do "apt-get update" on archived, oldstable or stable?

As you're finding, when you change from one Debian generation to another, unless you begin at the beginning of the dependency tree, apt-get or dpkg always seems to complain about an app depending on another app, or an app being used by another app, etc. For me this seems to mean that I have to force the installation at some point or other.

I've often wondered why daemons I install as part of an extension (eg acpid) will not auto start and I am obliged to enter something like "/etc/init.d/acpid start" - maybe you stumbled on the reason?

I don't like to play with 'force' options because I don't master apt or dpkg enough to fully understand all the implications of it. But you were right (in another post) and
Code Sample
sudo dpkg -i --force-all  /var/cache/apt/archives/file-rc_0.8.7_all.deb

solved my problem with invoke-rc.d while installing another package.
I'll mention it in the other post too.

original here.