Apt-get :: HD install, 404 error on mirrors

I used this settings:

deb http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free

and its working for me.


I strongly suggest, from personal experience, to try to stick with the oldstable as long as you can, until all the mirrors have gotten rid of it.

I just tried the trick of downloading cron from stable. It was the most useless cron I have ever used. OK, probably not cron's fault, but it was incompatible with DSL enough that it wouldn't run jobs. Using my good trusty friend Google, I tracked down a couple of working Debian mirrors still hosting oldstable. Changed the sources.list file to suit, and voila, working cron!

My point is this: oldstable is spelled differently to stable for a reason. Some packages MAY work fine from stable with DSL, there may not be enough different between versions to affect anything. Unfortunately, there are programs in stable that just won't work with DSL, at least not without a lot of messing around with settings and such. To help out a bit, I'll post a couple such servers here for you to use (as of the time of this post they are working). They're in sources format, so you can just copy and paste these lines directly into sources.list.

#deb http://ftp.br.debian.org/debian/ oldstable main contrib non-free
#deb http://mirror.aarnet.edu.au/debian oldstable main contrib non-free
#deb http://mirror.linux.org.au/debian oldstable main contrib non-free
#deb http://mirrors.usc.edu/pub/linux/distributions/debian oldstable main contrib non-free

Just remove the # from the beginning of one of those (and add a # to the beginning of any other sources for oldstable/stable), and run apt-get update. Hopefully, one of those servers will still be up for you.

What I want to know is, why is Debian appearing to be removing this version (woody) from their servers, when they've left up even older versions??? Unless they're just in the process of transferring woody to their archive servers with the other older versions. One can only hope, because apt in DSL depends on these servers!


Im having the same problem. I just toasted my DSl partition(playing where around where I should'nt have been in root).Usually when this happens, all I have to do is re-install DSL again and go throught the upgrade GNU,enable apt, and hit synaptic in the tool meny. Not so this time. I got the 404s and such,so I tried that suggestion about modifiing source.list and it worked(sort-of) Usually the first thing I re-install is sndconfig,only its not there anymore. There is alot of things missing. Does anyone know if the server was recently toasted? if so is there another mirror we could try?
I think its time I go to bed, I did not see the second page till after my post.
Quote (meltdown_override @ Jan. 05 2007,23:29)
is there another mirror we could try?

Did you read my post above? :p


Next Page...
original here.