Apt-get :: apt-cdrom does not work

I've just installed dsl to my usb pendrive and I thought I could easily install my old debian packages from the cdrom on it. When I run "apt-cdrom add" to add the Debian cdroms to the sources.list it tells me the following:
Code Sample

Identifying.. [a1f8c3b5798c8af32421672ed84b141e-2]
Scanning Disc for index files..  Found 0 package indexes and 0 source indexes.
E: Unable to locate any package files, perhaps this is not a Debian Disc

But it is an Original Debian Disc
Could someone help me?
yours xkill

I am not sure about the apt-cdrom method but what I do is just mount the filesystem over top of the /var/cache/apt/archives directory and as long as all the dependencies are present there is no problem.  For example, I burn all my .deb files to CD.  When I need to reinstall DSL or something I get apt set up (enable apt/synaptic) then I do:

sudo mount /dev/scd0 /cdrom
sudo mount --bind /cdrom /var/cache/apt/archives

when I run dpkg or apt or synaptic the system just assumes that I have already downloaded the files because they are there.  You don't need to use a cdrom though the packages can simply be copied into the /var/cache/apt/archives directory if you wish instead of doing the mount, I just find that if I have them already on cdrom I use them from there.  Copying them to a single directory would be better though if they are in various places (i.e. in subdirectories or seperate cdroms etc...).

original here.