Laptops :: Colors and resolution in Compaq Armada 1530


I install the latest version of DSL (1.5) in my laptop.
My laptop has: Pentium MMX 133Mhz, 32MB, video adapter CL-GD7548 1.40 IPCI, CSTN 12,1" (in Win95 working perfect SVGA-800x600-256 colors). The installation on hard disk it was without any kind of problems.javascript:emoticon(':)')
I made login as root and the GUI it was awful. I run and set Xvesa xserver at 800x600x8. The same awful GUI. Then I try the Xfbdev xserver and give me the following error: [XIO: fatal IO error 104 (conection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining].
I try several combination of resolution-color depth in Xvesa and nothing at all (no icons, awful colors etc.). I put in lilo.conf vga=771 and I make some combination with Xvesa. Result no icons, awful colors etc.
I change the vga=771 to 787 and again combination with Xvesa. Result: no icons, awful colors etc.

Please tell me what goings wrong? How to fix the problem?
Any suggestions?

Best Regards,

Not the exact model, but it might give you a start bud!

starting from

Hope that helps


That native resolution for that laptop seems to be 800x600, so stick with that resolution.  Just try changing the color depth.  My guess is that it uses 16 bit (vga=788), but I believe that was the default value, wasn't it?  If you are feed up with changing the settings try xfree86 (from the DSL repository).  You will need to know what type of adapter is in the laptop and well as the amount of memory used.

Let us know!

I gotta learn to type faster...

I test your suggestions and nothing.....
I install the XFree86 and nothing....

If you think something please inform me....
I continue the tries until to find a good solution.....

Thank's a lot

Hi Ilias,

I have an Armada 1530 as well and I've tried to get more than 256 colors and nothing!
Using Mandrake 9.0 I got 256 colors. The same using Win98 2nd.
Others distros (Debian, Knoppix, Slack, etc) sometimes I got graphical installation but, after resetting, only command prompt.
No graphical interface.
External monitor works fine.
Today I found the link below (in French) were says 16 bit depth
HP page is a s*** because no manual is available.
So now I'm not sure how it works....


Next Page...
original here.