Multimedia :: Can't get sound working

I have not been able to get sound working in DSL 3.01 and would be very grateful for any advice.

The computer I'm using has an SiS7019 soundchip.

At, I was able to download the file xlr54-kernel-2.4.31-vortex86.tar.gz and extract from it a compiled driver for the SiS7019.

That driver was said to be installable (when using X-Linux, also available at the same site) simply by executing the command "# modprobe sis7019".

At, there was an uncompiled version of an SiS7019 driver for the v 2.4.x kernel. The Readme which came with that version said that the driver was for the "RedHat kernel".

The installation instructions involved compiling the sis7019 module and, if necessary, the soundcore and ac97_codec modules as well. Next, one was to copy the module(s) to /lib/modules/x.x.x/kernel/drivers/sound. Finally, one was to edit /etc/modules.conf by adding:

below sis7019 ac97_codec soundcore
alias sound-slot-0 sis7019

I tried to combine the compiled sis7019 module from dmp with the instructions from ltsp.

I edited to load soundcore, ac97_codec and sis7019 in that order on booting up. I had to use the -f option with the sis7019 module because of the kernel mismatch, but it loaded and lsmod showed all three modules. That seemed to me to have the same effect as adding "below sis7019 ac97_codec soundcore" to /etc/modules.conf.

I didn't know how to set up the alias command, so did nothing about that.

I then tried to play an mp3 file with xmms, but without success.

Xmms didn't appear to open when I clicked on its icon on the desktop.

I next went into Emelfm, selected an mp3 file, right-clicked on it and put xmms into the "open with" box.

That didn't work either. I got some output that I understand from reading posts here was irrelevant, referring to omitted, but non-essential, libraries, and then "end of output".

What else should I be doing to get sound? Is it as simple as setting up the alias command? If so, where do I put that so that it's permanent? Should I be doing more? If so, what?

Thanks for any advice,


I don't think trying to get things working when you're using things that are meant for different kernels is a good idea.

If you want to continue trying with the 2.4.31 you should try DSL v2.1b (and some versions around there), where you may have a better chance. (DSL currently uses 2.4.26-knoppix).

If you want to compile it, the module generated will most likely work.

I think the alias can be placed in one of the startup/sourced scripts - most apps look at the default sound-slot-0

Thanks for taking the trouble to reply, ^thehatsrule^.

I believe I solved the alias problem by adding a line to .bashrc--now, when I type alias at the command line, I get the output:

alias dir='ls'
alias sound-slot-0='sis7019'

However, that's done nothing to get xmms going, so I would like to try to compile sis7019 from source, as you suggest, rather than try to use the pre-compiled version for kernel 2.4.31.

My grasp of these things is tenuous, however, so I don't know how to proceed.

The instructions that came with the source version from LTSP begin: "Check that you have kernel-source in /usr/src/x.x.x".

I downloaded kernelsource.dsl to my /cdrom directory and rebooted. On bootup, I saw that kernelsource was loaded, but I don't know how to get "kernel-source" into the DSL equivalent of /usr/src/x.x.x, which I'm assuming is /usr/src/linux-2.4.26/.

How do I do that?

Thanks again,


You don't have to reboot to use the mydsl system.

And yes, that's the correct dir.

I haven't been able to compile the sis7019 module, as ^thehatsrule^ suggested I might try.

My problem is that I haven't enough space on my tiny computer to install both the kernel-source and the gcc extensions, which I take it I would need. The bootup process aborts when I try.

Before, however, I give up on trying to get sound going, I'd like to exclude the possibility that my problem is with xmms, rather than with my pre-compiled sis7019 module.

Is there some other simple test I should try to see if I the module is working?


Next Page...
original here.