HD Install :: Frugal Install -- No MyDSL?

When I look at the /mnt/hda3 directory in the terminal it doesn't show a mydsl directory.
You have three partitions, but one of them is swap, which means it's not a filesystem.  You actually have two mountable partitions, so I'm guessing what you thought was hda3 is actually hda2.  Do you see the mydsl directory in /mnt/hda2? You will probably need to mount it first.

If you change your bootloader's configuration to use mydsl=hda2, or remove the mydsl option entirely, it will probably work.  If you're using Grub I can help with that, but I'm afraid I have no experience with Lilo.

If you skip the myDSL step during installation, or remove the mydsl option from the boot loader after installation, DSL will automatically search for a mydsl directory (unless you specify "base" as a boot option). Setting the mydsl option disables this autocheck, gives the user the ability to chose a specific directory, and probably saves a quarter of a second of boot time.

That worked.

When I set both the install and MyDsl option to hda2 (now my only partition) it worked perfectly.

Strange that it wouldn't install correctly using a second partition for the MyDsl


original here.