Site News :: DSL v3.4.3

A minor release for for DSL v3.4 is now available.

Change Log for DSL v3.4.3
* Updated icontool.lua - select icon by image
* Updated torsmo v0.18
* New automatic update of etc.ld.cache for uci .so files
* Updated functions5.lua
* Updated mydslDownload.lua
* Removed obsolete and unused files and directories

I would like to thank mikshaw for his lua code for icon display in the updated icontool.lua.

Thanks to andrewb for contributing the updated torsmo.

-- Robert

Is it possible that the "new automatic update of etc.ld.cache for uci .so files" could cause strage behaviour if an identical lib exists in the base dsl system?

The reason I ask is that I compiled glibc-2.3.2 - principally to get the headers - and did not clean up all of the duplicated libs. A tar.gz extension works but a uci extension gives a segmentation fault when I try to load it - I built the uci twice to be sure there were no file errors.

The process is doing nothing more than adding to /etc/ and running ldconfig. You can always edit your /etc/ and manually run ldconfig. Are you running legacy? Is there any difference?
I tried booting from two different usb sticks - one legacy and one without legacy - and the result was the same:
Code Sample
$ mydsl-load /tmp/build.uci
/tmp/build.uci sucessfully loaded!
/usr/bin/ line 10:  2628 Segmentation fault      iconsnap.lua

I tried a couple of other uci and they loaded without errors. I'll try removing the libs that are duplicates of those in the base dsl and see if that changes anything.

Next Page...
original here.