Release Candidates :: DSL v4.0rc1

Changed kernel from to 2.4.31 to gain user contributed modules, e.g., ipw2* and nvidia.
I might have missed it earlier, but why the sudden change in the kernel?  Is this only due to ipw2* and nvidia (some problem with 2.4.34 or just not built)?

In any case, I feel this is a step back, as I was led to believe 2.4.34 was tested so that keeping a relatively recent kernel could help those with newer hardware.  And then users of older systems could use 2.4.26

Note: if that certain subsystem hasn't changed, users could try "forcing" the module, i.e. with insmod -f

2.4.31 is the high water mark for backported, patched, and hacked  modules that are not officially contained with the kernel build process. Many are very popular, e.g., ipw2x00. This was discussed in several threads. Using was actually a negative in that many users who are still using 2.1b were still not able to move forward and enjoy the many feature enhancements since the releases of 2.1b.

It would appear that there is little to no interest from third party vendors to supply or continue to update backports to the 2.4.x series. All have moved on to 2.6 series. While that is unfortunate,
should it change, doubtful, I would re-consider and re-evaluate at such time.

Using 2.4.31 will hopefully allow 2.1b users to join with the rest of us who are staying current with DSL development.

Great! It is moving forward ..

But although I have burned the CD this time on 2 different computers with 2 different programs ( and I think also a different (this time rewritable) CD ), there were again a lot of I/O errors shown during boot as there were already with the first alpha release.
Nevertheless I have got to the desktop screen and everything ( mouse, keyboard, .. ) was working so far.

Then I wanted to do a USB pen installation in order to test it on my new computer.
After aprroximately 1, 2 or 3 seconds and the words partitioning / formating, the installation stopped. I think there was also an I/O or read error shown.
I have tried 3 different USB pens. Always the same problem.
Does the USB pen installation routine work without any problem?

Unfortunately all the error messages have only been shown for some milli-seconds.
Is there a way to log them to a text-file?

If you are getting I/O errors during boot from CD, I would not proceed to use anything.

The new pendrive grub script, was written while I was waiting in airports during my travel to Linux World. It has been tested on 128, 256, 512 and 1 GB pendrives. It was demo'ed at the Linux World booth. Since returning, I used and booted from it here on a couple of machines. It tries to address the issue of Windows not allowing one to see multiple partitions. So the script tries to calculate and create the small partition as the second one. This allows the remainng larger vfat one to be seen by windows.

Still, it is new and this is still a testing cycle, so proceed with caution.

If you are using SATA drives, I would not use this or any automatic script as your main drive is likely called sda1.

The new pendrive grub script - does this allow me to install DSL on a pendrive and use it even if my BIOS does not support USB booting? Sorry if this is too dumb a question to ask...I am a old time DSL user but have not kept myself up to date in last several months.
Next Page...
original here.