Release Candidates :: DSLv3.0RC2

The second release candidate of DSL is now posted here.

The change log for DSLv3.0RC2

1. New DSL now boots to unionfs
2. New boot option "legacy" to boot without unionfs
3. Moved MyDSL local extensions from emelfm to MyDSL desktop icon (mydslPanel.lua)
2. New mountable MyDSL extension type unc with automatic branch management.
3. Adjust Getting Started/Dillo screen to support booting 640x480
4. Added ACPI modules for newer power managment support
5. New FUSE support
6. New sshfs support
7. Fixed bug in kbdconfig when changing keymaps.
8. New theme "A Penguin with a Hat"
9. New sample unc extensions, abiword, cups, gnu-utils, and opera852


If you have been testing v3.0 and/or have a backup then you should upgrade the following:

cp /etc/skel/.emelfm/buttons /home/dsl/.emelfm/.
cp /etc/skel/.emelfm/filetypes /home/dsl/.emelfm/.

Ooh, downloading now. I promise i'll be good this time my knee is healing and i cut back on the meds.
Hmm, I love the new myDSL load in myDSL browser.

Okay i'm still having problems, after using the DSL browser to download fluxbox1.14.uci(also tried conky.uci) it says i need to manually mnt. so i open emelfm to go to /tmp so i can mount it but if you click on /tmp it locks emelfm up. Tried to load from the new MyDSL load same thing just sits there. I then used terminal to cd to /tmp once i hit> ls enter, lock up.

Okay, i tried down loading it to /dsl/ and loading with the MyDSL load
and get the same message. here's a pic from xpaint->

But i'm glad to report i had no problems loading .dsl's from my usb pen with the new mydsl load.

to be continued...

I installed rox to try and look at /tmp and rox shows /tmp as a mounted file, is it suppose to be mounted?
Nice work on this RC - The new MyDSL extension loader seems to have alleviated the problems with Emelfm and other parts of the system "locking up".  I have tried out a few extensions I have created, XFree86.unc - GTK-0705.unc, and they seem to work well.

Suggestions -

Modify the UCI Tool to show both uci's and unc's that are mounted.

Have MyDSL extension loader open in the last viewed directory (Okay, I am just to lazy to click through directories - :) )

P.S.  A short guide on "properly" creating unc's would be helpful, I think I am doing these right, but want to be sure.

Next Page...
original here.