Window Mangers :: I can't boot straight to JWM desktop

Hi all,
I have DSL (2.3) frugal installed on my machine (hda1) with a backup on hda5 (second partition of the same hd) and everything works fine.

I observed that JWM needs 2 processes less than fluxbox and I would like to make my machine directly boot in JWM desktop.

So, I put the cheat code 'desktop=jwm' in my grub boot line, but my machine always boots in fluxbox.

Here is my boot line in grub:

kernel /boot/linux24 root=/dev/hda1 quiet vga=791 noacpi noapm dma noscsi frugal desktop=jwm home=hda5 opt=hda5 mydsl=hda5 toram

How can I get JWM directly at boot?

Thanks a lot for your help!

*edited to correct an inaccurate assumption*

Edit /home/dsl/.desktop: replace "fluxbox" with "jwm"
Then make sure home/dsl/.desktop is included in your backup.


thank you a lot for your prompt answer. I did it, but I have a little problem: when rebooting, dsl makes the backup automatically, so that my the changed /.desktop is replaced with the default one (with fluxbox).

Have I to boot with norestore in order to avoid it...? I guess yes, but I'm not sure; norestore won't load your preferences at boot, but the backup will be done automatically at reboot/shutdown... or am I missing the point?

I don't have time to test it now, that's why I'm doubtfully asking; without any warnings, I shall try it.

thanks again for helping me!

mikshaw is correct. The file .desktop.
Also you can use the menu to switch desktop to jwm.
The switch desktop updates the .desktop automatically.
When you allow a normal shutdown and the backup occurs it will persist your desktop setting.

ZoOp: I have a feeling that there is a problem with the way you're using backup/restore.  If the modified .desktop file is being overwritten by the default .desktop file, then it's not properly being backed should do the opposite of that.  Another possibility is that you switched back to Fluxbox before shutting down.  If you did that then the backed up .desktop file will have "fluxbox" in it instead of "jwm".

If you use "norestore" your previous backup will not be restored, and you will not create a new backup when you shut down unless you enable your backup again during that session.

Next Page...
original here.