System :: DSL 4 kernel headers ?

You're still not getting what I wrote.  Plus you're writing steps that are not recommended. Please re-read my posts.
Thanx anyway for your time,
I will reread your post.



This is what you are looking for...
kernel code for DSL 4.1

Take a look in this folder, there are 3 other files you'll need.

I compiled all of the modules enabled by the dsl-4 .config file using compile-3.3.5.uci (mydsl testing) and the full 2.4.31 kernel sources - there are some details in the info file.

The bluetooth and irda modules compiled in this way seem to work fine.

I followed your advices:
Installed Kernelsource 2.4.31, installed compiler gcc1-with-libs (and later tried also compile-3.3.5.uci) -
then adjusted Makefile of my module (RT61 WLAN PCMCIA card)  -
then ran <./Configure> successfully.

Then <make> and got the error:

gcc -D -I/usr/src/linux-2.4.31/include -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include /usr/src/linux-2.4.31/include/linux/modversions.h -DAGGREGATION_SUPPORT -DWMM_SUPPORT -Wall -Wstrict-prototypes -Wno-trigraphs   -c -o rtmp_main.o rtmp_main.c
<command line>:138471553:59592: /usr/src/linux-2.4.31/include/linux/modversions.h: No such file or directory

Looked into /usr/src/linux-2.4.31/include/linux and indeed it is full of files, but there is no <modversions.h>  

GRRR: In DSL3.4 it was present   :-(

Now I will try to take the old kernel-source and copy the missing file(s) over to the new kernel-source. If this works I will try to strip the huge kernel.source down to a size according to the old one (3 MB).
If this is successful I will publish the kernel-source-2.4.31 as zip-file.


Next Page...
original here.