Apps :: The Gimp 2.4

Hello all app contributors to DSL!

I just saw that Gimp has come with it's sharp 2.4 version. Wouldn't it be nice to have an extension for DSL of that one. Unfortunately it's kind over my head to do one myself but if someone that has the skills is up to it I would be more than happy. Thanks beforehand!

Have fun guys,

I didn't look at the requirements for gimp-2.4, but it's a reasonable bet that many dsl libs will need to be upgraded and you will end up with a large (20MB+) extension - is this what you're looking for?
Hi Juanito!

That would be perfect. To me size doesn't matter since I'm running DSL from a 8 GB CF card. So anything that works would be greatly appreciated!

As always have fun with DSL,

Excerpt from the gimp-2.4 install file:
1. You need to have installed a recent version of pkg-config available

 2. You need to have installed GTK+ version 2.10.13 or newer.  GIMP
    needs an even more recent version of GLib (>= 2.12.3).  It also
    wants Pango (>= 1.12.2).  Sources for these can be grabbed from

 3. We require PangoFT2, a Pango backend that uses FreeType2. Make
    sure you have FreeType2 and fontconfig installed before you
    compile Pango.  FreeType2 can be downloaded from  Fontconfig from  GIMP depends on freetype2
    being newer than version 2.1.7 and fontconfig 2.2.0 or newer.
    Older versions are known to have bugs that seriously affect
    stability of GIMP.

 4. We use libart2. Grab the module libart_lgpl out of GNOME SVN or
    fetch the tarball from

 5. We use dbus-glib if available. Grab it from

 6. You may want to install other third party libraries or programs
    that are needed for some of the available plugins. We recommend
    to check that the following libraries are installed: libpng,
    libjpeg, libpoppler, libtiff, gtkhtml-2, libmng, librsvg, libwmf.

 7. The Python extension requires Python development headers to be
    present. You will also need PyGTK and the respective development

- on the positive front, the compile extension I'm working on contains the latest version of pkgconfig...

Well Juanito!

I checked up the requisits for Gimp 2.4.x and just realized that it was way over my head trying to do an extension of that. So I guess that's it!

have fun,

Next Page...
original here.