Apps :: sound/modify modules.conf

Hi!  I have an old Toshiba 460CDX laptop, Pent-1, 1.65MHz, 40MB RAM.  The sound didn't work but after some digging, i found that i just needed  get into a terminal as root and type:
       modprobe cs4232 io=0x534 irq=5 dma=1 dma2=0
It works great now.  The post said to add that line to my modules.conf file to load the module at boot time; however, the modules.conf file located in /etc is a big red "ERROR" icon (using Rox-filer); when i right-click to show target, i get a message "Directory '/KNOPPIX/etc' is not available.  This happens even when i try it with root privileges.

How do i get this module to load automatically at startup?  Where do i put it, and do i put that exact line in?

Thanks for the advice!

Add the line "modprobe cs4232 io=0x534 irq=5 dma=1 dma2=0" to /opt/ instead.
Thanks! :)  I'll try it when i get home.  If i don't repost -- it worked.
Hope posting to this old topic gets noticed...

I am trying to use Audacity with my sound configured as stated above -- but while i can play just fine, i cannot record with any clarity.  I have tried all kinds of tweaks in the program and in my sound settings, all to no avail.  I downloaded a different record program through the package management system and it had the same problem (simply horrid sound).  There must be some configuration i need to make somewhere.  I am using dsl 4.2 -- haven't tried 4.3 yet.

Note that the sound quality is fine on the Windoze side of the laptop, but with my low resources i get skips in the recording even with all other apps including explorer shut down.  I am hoping dsl will use few enough resources to enable me to record.


You could try with the alsa.dsl mydsl extension instead - the alsamixer probably allows more "tweaking" of settings for recording. Note that it might be worth a trip to the alsa web site to check that your sound device is supported.
Next Page...
original here.