Printers :: I need a printer

Hi all
i need to buy a printer and install it into a dsl-n system
MB is via VB7001; i got 1 usb port and no lpt port so i need an usb printer
plus, i whant doing it easy, less things to install less problem could arise, faster i resolve this

so, my approach is:
1) check on robert's post seeing what printer driver is known by deafult from DSL. For instance i could choose cdj550 (hp deskjet printer)

2) go or google or like and search a printer i can use with this drivers. for example a deskjet 550 :)

3) i buy the printer

4) plug the printer into dsl and it work? or there is something else to do? (like installing, configuring, and sacrificing some lambs to make cups work)

No need to install cups or hplip just to print. Sacrificing some lambs might be necessary though, just to make Tux have a good mood :;):
In 4) after plugging in you must use apsfilter (printer setup) to set up all the settings, driver etc. Take a note of the printer's name. And then edit your .xinitrc by adding "export PRINTER="my-printer-name"" right above "case". This makes your printer the default.

If you have a HD-install or backup set up, all this will be saved and you won't need to do anything afterwards. If you have a frugal install you need to add some entries to filetool.lst.
The wiki has good instructions:

apsfilter? cool
i'll try it

btw, now i'm trying a different way

i have an epson stylus phot 750 i already use on a fedora with cups
so i installed cups (luckily, it was already installed on my dsl-n)
this is what i did:
1) start cups with /etc/init.d/cupsys start
2) add printer
3) following all process to add printer
4) now i successfully added printer
5) print. it give me some errore "usb port not found" or something; i try to "modify printer" to set another usb port.
6) if i select usb port 3 (maybe the port where i plugged the printer? :D ) stop giving me error. woot. wow. \o/ now it saying "printing page 1, 10%" and like. but no print is done
i mean: cups state "printing done" but printer does'nt print -_-

already tried to install newer version of cups (downloaded new .dsl from website) and also starting cups with "sudo"


The wiki has good instructions:
I tried but...
in the page you pointed me i read:
«How to Set Up a Printer With Apsfilter

Access Apsfilter by clicking on the "Printer Setup" button in the DSL Control Panel

The first screen of Apsfilter asks you to accept the license agreement.»
and blah blah blah blah...

now, if i click on "printer setup" on dsl control panel, it open seamonkey on "localhost:631" page (i mean: on cups administration setup panel -_- )
so, no apsfilter here -_-

i can just add the "export PRINTER=""" part into .xinitrc, or i need also something else? (for example, learning what's the name of this printer?)

ty vm for help

original here.